Su questo sito utilizziamo cookie tecnici e, previo tuo consenso, cookie di profilazione, nostri e di terze parti, per proporti pubblicità in linea con le tue preferenze. Se vuoi saperne di più o prestare il consenso solo ad alcuni utilizzi clicca qui o sul pulsane Privacy Policy. Cliccando in un punto qualsiasi dello schermo, effettuando un’azione di scroll o chiudendo questo banner, invece, presti il consenso all’uso di tutti i cookie
Stampa
Categoria: Cisco
Visite: 1088
Stella inattivaStella inattivaStella inattivaStella inattivaStella inattiva
 
Continuiamo con le VPN e vediamo come configurare una L2TP con un router Cisco.
Per l'esempio sotto ho usato un 1841 con OS: c1841-adventerprisek9-mz.124-24.T2.bin
Immagino che la maggior parte dei router supporti questa configurazione, magari con qualche piccolo adattamento o modifica.

I Systemi OSX,  iPhone e Ipad compresi come anche Android e Windows supportano nativamente le VPN L2TP. 
Sono sicure e perfettamente supportate.

Ad un Router configurato correttamente e con ip pubblico statico...

SOTTO LE PARTI CHE SERVONO.

-----------------------------------------------------------

username USER password 0 PASSWORD (utenti che vogliamo usare per collegarci creiamo quanti vogliamo) 
!
aaa new-model
!
aaa authentication ppp VPDN_AUTH local
!
vpdn enable
vpdn-group L2TP
! Default L2TP VPDN group
accept-dialin
protocol l2tp
virtual-template 1
no l2tp tunnel authentication
!
crypto isakmp policy 1
encr 3des
hash sha
authentication pre-share
group 2
lifetime 86400
!
crypto isakmp key CISCO123 address 0.0.0.0 0.0.0.0 (CISCO123 pa PSK che vogliamo usare per la configurazione nel client)
!
crypto ipsec transform-set L2TP-Set2 esp-3des esp-sha-hmac
mode transport
!
crypto dynamic-map dyn-map 10
set nat demux
set transform-set L2TP-Set2
!
crypto map outside_map 65535 ipsec-isakmp dynamic dyn-map

interface Loopback1
description loopback for IPsec-pool
ip nat inside
ip address 192.168.155.254 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0 (LAN INTERNA)
ip nat inside
!
interface Virtual-Template1
ip unnumbered Loopback1
ip nat inside
peer default ip address pool l2tp-pool
ppp authentication ms-chap-v2 VPDN_AUTH
!
ip local pool l2tp-pool 192.168.155.10 192.168.155.30
!
interface FA0/1 (SE QUESTA E’ L’INTERFACCIA WAN, ALTIMENTI METTERE LA VOSTRA)
ip address 88.32.23.44 255.255.255.248 (ESEMPIO IP WAN)
ip nat outside
crypto map outside_map

ip nat inside source list NAT-ACL interface FA0/1 overload
!
ip access-list extended NAT-ACL
10 deny ip 192.168.168.0 0.0.0.255 192.168.155.0 0.0.0.255
(NO NAT PER LE RETI INTERNE)
20 permit ip 192.168.1.0 0.0.0.255 any
(PER LA NAT DELLA LAN INTERNA VERSO OUTSIDE)
30 permit ip 192.168.155.0 0.0.0.255 any 
(PER LA NAT DELLA LAN L2TP VERSO OUTSIDE)

------------------------------------------------

Ciao Luca